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1. Introduction 

1.1. Where to obtain the software 
You can obtain the latest version of the student edition of System Architect on CD-Rom from: 

 
http://vig.prenhall.com/catalog/academic/product/0,4096,0131423533,00.html 
 
ISBN:  0-13-142353-3  (although this comes up blank in both amazon.co.uk and .com) 
 
The cost is rather variable based upon where you live, for example in the US it is $34 but when posted to 
the UK has an additional $30 shipping import charge  (= £40.13 total).  Therefore you may want to make 
arrangements between yourselves for obtaining copies. 

 

1.2. Before you begin this tutorial? 
Before you work through this tutorial you should have the following knowledge and skills: 

• A basic understanding of the systems development life cycle 

• Knowledge of what an Entity Relationship Diagram is and be able to draw one by hand 

• An understanding of the basic terminology used in Entity Relationship Diagrams.  

• A working knowledge of Microsoft Windows (98, ME, NT or 2000) including working with multiple 
applications and windows, dialog boxes, and so on 

• Preferably some experience with using a DataBase Management System such as Access or 
Oracle, although this is not assumed in this tutorial. 

 

If you feel that you are unable to answer yes to any of the above criteria a good starting point it to work 
through either Robin Beaumont’s ERD tutorial at 

  
http://www.robinbt2.free-online.co.uk/virtualclassroom/chap11/s9/erds_1.pdf   
 

or Richard Holowczak’s at 

 
 http://cisnet.baruch.cuny.edu/holowczak/classes/3400/entityrelationship/  

 

1.3. What are the aims of this tutorial? 
This tutorial is the first in a series to introduce you to using a specific CASE tool, Popkin’s Systems 
Architect Student Edition (SA/SE). Because this is the first tutorial it provides you with screen by screen 
details of what to do. The aim being to familiarise you with the most common, basic features of SA. By the 
end of this tutorial you will be feel confident with navigating around SA and with the basics of drawing 
diagrams. Subsequent tutorials assume you have this knowledge and therefore provide less detailed 
instructions.  

While the complete CASE tool has hundreds of features capable of addressing the complete systems 
development life cycle, this tutorial will focus only on a small, but important subset that of creating a ERD 
(Entity Relationship Diagram). 
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2. Starting Up SA/SE 
It is assumed that you have SA/SE installed 

In this section, the basic techniques for starting up the Popkin Systems Architect Student Edition (SA/SE 
for short) will be described.  SA/SE is a Windows software application that runs within the Microsoft 
Windows 98, ME, NT, XP or Windows 2000 operating system. As with most Windows applications, 
starting SA/SE is simply a matter of clicking the left mouse button on the Windows Start menu as shown 
here:   

 

Start the program by going to "Start" menu, selecting (All) Programs, then Popkin Software then System 
Architect by clicking on it as shown in Figure 1:  

 

 

This is where you click to 
start SA/SE 

Figure 1 Windows Start menu showing SA/SE menus and icon  
Note that on your own PC or in your School’s computer lab, this menu may appear slightly different. 
When the software is started for the first time, two dialog boxes appear a Student version warning and a 
Configuration dialog box as shown below in Figure 2.  

 

Click OK 

 

Click 
CANCEL 

Figure 2 SA/SE Student version warning and Property Configuration 
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For the Student Edition of SA/SE, simply click on the Cancel button. Once this is done, this dialog box 
may hopefully not appear and irritate you in the future.  

Next, you may see a SA/SE “Tip of the Day”. Click on the Close button to close this dialog box.  

Finally, you may also see the Audit ID dialog box as shown in Figure 3. Type in any integer (whole 
number) for this Audit ID and then click on the OK button to close the dialog box. As with the 
Configuration dialog box above, this may only appear once.  

 
Figure 3 The Audit ID Dialog Box  

 

Once these few startup dialog boxes have been dismissed, the main SA/SE screen should appear. The 
main screen is shown in Figure 4.  

Button 
(Tool) bar 

The browse 
detail 
window 

The browse 
window 

Figure 4 Main SA/SE Screen 
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The SA/SE main screen is divided into four main sections. Along the top are a series of menus and a 
button bar. The Browser appears on the left hand side and Browse Detail appears in a small window 
below it. The right hand side of the screen is reserved to display diagrams and models.   

The Browser is organized into a series of tabbed sheets as can be seen in Figure 4. By default, the All 
Methods sheet is displayed. For this tutorial, we will make use of the Data Modeling tab to create an 
Entity Relationship diagram. Depending on the size and resolution of the PCs screen, the application 
window may appear smaller and this may cause the Browser to display only abbreviations (e.g., “AM” for 
All Methods) on the tabs. If this is the case, try maximizing the main application window or drag the 
separator between the Browser window and the diagram display to the right to expand the Browser 
window.  

All of the related models for a project are stored in a SA/SE Encyclopedia. This is also called a Data 
Dictionary or Repository in most CASE tools and in systems analysis textbooks. In the full version of 
SA/SE, the user may save a related set of models for a project into an encyclopedia that they name. 
However, in the Student Edition of SA/SE, only four such encyclopedias are available. These are named: 
Project1 to Project4. There are also to other encyclopaedias one provides examples of the various 
diagrams and the other is the official SA/SE tutorial provided by Pokins.  

Before we begin work it is a good idea to clear the screen of clutter by closing the ‘Zachman Framework’ 
window as shown in the diagram below. 

Figure 5 Closing the Zachman Framework window 

 

We are now ready to begin. For the purposes of this tutorial, Project1 is assumed to be empty (and will be 
if no one else has used it), we will use this encyclopedia to create different but related models.  
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To make certain the proper encyclopedia has been chosen, at this time, pull down the File menu and 
select the Project1 menu item as shown in Figure 6. 

 

 
Technical Note: 

Encyclopedias are 
actually directories on the 
hard disk where SA/SE is 
installed. Use Windows 
Explorer to look in the 
directory where SA/SE is 
installed (C:\Program 
Files\Popkin Software\ 
System Architect Student 
Version\Encyclopedias by 
default) and locate the 
Project1 directory there.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6 Selecting the Project1 Encyclopedia 
 

After selecting the Project1 encyclopedia should the Configuration dialog box appear (as in Figure 2), 
simply click Cancel to close it.  

In the next section, a basic Entity Relationship diagram will be defined using the Data Modeling tab in the 
browse window. 

3. Data Modeling using Entity Relationship Diagrams  
The following section is based on materials from these popular SA&D textbooks:  

• Whitten, Bently and Dittman 5th edition. Chapter 7 Data Modeling and Analysis  

• Kendall and Kendall 4th edition. Chapter 17  

• Hoffer, George and Valacich 2nd edition. Chapter 10  

In this section, a basic Entity Relationship data model will be created with two entities and a simple 
relationship between them.  Make certain that the Project1 encyclopedia is currently selected and that it 
contains no other models.  

The business we are modeling is a Travel Agency. In the Agency, a Travel Agent will make a Reservation 
for a Customer. In this section we model the Travel Agency and the Reservation entities. The resulting 
diagram should appear as in Figure 7.  

 
Figure 7 The Completed Entity Relationship Diagram  
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3.1. Creating a new diagram 
There are several ways to create a new diagram and one of the easiest ways is to click on the New 
diagram icon on the tool bar as shown below. 

 
Figure 8 The New Diagram icon 

The important thing to realise is that the list of the various diagrams you are offered depends on what you 
have selected in the browse window previously. Try the following experiment. 

Click on the All tab then the Diagrams option. Then click on the new diagram icon where you should be 
presented with a list similar to 
the one below. When you have 
finished scrolling up and down 
the list close the window by 
clicking the X 

 

 

 

 

 

 

 

 

Figure 9 The complete set of Diagrams available to you 
For our project1 we will use the type of diagram appropriate to data modelling – the Enitity Relationship 
Diagram (ERD for short) and to ensure this we will select the Data modelling (DM) tab first. 
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Click on the Data Modelling tab in the browse window. The entries Models and Shared should appear. 
Click on the models entry with the Right mouse button and select New from the pop-up menu. Select the 
Entity Relation item by double clicking on it in the list as shown in Figure 10.  

 
Figure 10 Selecting an appropriate Diagram 

A dialog box should appear asking for a name of the new diagram. Name this diagram Travel Agency 1 
and click on the OK button.  More than one diagram may belong to a data model so SA/SE needs to 
know in which model this particular diagram resides. Therefore another dialog box appears and prompts 
for the name of the data model. For this example, type Project Data Model 1 and click on the OK button. 
No other options need to be selected at this time. The following diagram shows the two dialog boxes. 

 

Figure 11 Naming the ERD and the Model 
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At this point, several new objects are created in the Project1 encyclopedia. To see the new entries, go to 
the Browse window and click on the + signs next to Models and open up the sub entries of Diagrams and 
Entity Relation under Project Data Model 1. They should appear as in Figure 12.  

 
Figure 12 New Data Model and ER diagram  

 

To start drawing the actual ER diagram, double click on the Travel Agency 1 entry (as shown above). You 
should now note two things: 

• the Browse Detail window (bottom left hand corner of the screen) shows a blank white rectangle  

• the right hand window (the drawing panel) is also blank and ready for drawing.  

In this example two entities called “Travel Agent” and “Reservation” will be created as seen above in 
Figure 7. To begin creating an entity, locate the Entity icon on the button bar as shown in Figure 13 and 
click on it. The mouse cursor should change to a pen  

 

 

The drawing toolbar 

Figure 13 The drawing toolbar for Entity Relation diagrams with the Entity tool highlighted  
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Using the Entity tool, click on the empty space in the right hand window. When the new entity appears, it 
is given a default name. Type over this name with the new name of the entity: Travel Agent as shown in 
Figure 14  

 
Figure 14 Naming the new entity travel agent  

 

Click the entity tool once more to the right of the Travel Agent entity and name this new entity 
Reservation. Should you forget to rename the entities or mistype their new names, edit the names as 
described in the following paragraph. You should now have a diagram similar to the one below. 

 
Figure 15  The two new entities 

 

 

 

3.2. Editing Names and Attributes for the Entities  
 

Go back to the drawing toolbar and get rid of the pen-shaped cursor by clicking on the “Select-Mode”   
icon (the arrow )        on the very far left, alternatively you can press the Esc key. Now the selection 
cursor should be back in effect. This selection cursor can be used to drag and move the entities around, 
for example, if you created them too close together. The selection arrow can also be used to edit the 
name of an entity as well as to add attributes to the entity.  

In this example, attributes will be added to the Travel Agent entity. Position the cursor over the Travel 
Agent entity and click with the right mouse button. Then choose the Edit item from the pop-up menu. In 
the dialog box that appears, the entity name can be changed or corrected if necessary and the space 
below the entity can be used to add attributes. For this example, the following attributes will be added:  

 

Name Primary Key (PK) Data Type Qualifier 

Agent_id Yes character 10 

Agent_name No character 30 

Agency_phone No character 12 
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Fill in the dialog box as it appears in Figure 16. Be certain to check off the PK column for the Agency_ID 
as this will indicate Agency_ID is the primary key (or identifier) of the Travel Agent entity.  

 

 
Figure 16  Adding attributes to the travel agency entity 

 

Once the attributes have been added, click on the OK button to close the dialog box. The display should 
now changes to show the attributes for the Travel Agent entity.  

 
Figure 17  Resizing the entity to show all the attributes 

 

Repeat the above exercise by adding the following attributes to the reservation entity. 

Name Primary Key (PK) Data Type Qualifier 

code Yes character 10 

Reservation_date No date 10 

Room_type No character 10 

 

You may be wondering why the data type has a qualifier (i.e.length) of 10. Basically this is so that it 
conforms to the Date type as defined in ISO 8601 concerning format, For example: "1994-11-05". This 
information was taken from the excellent SA help file, with which you should make yourself familiar. 
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3.3. Defining a Relationship among the Entities  
At this point, two entities have been defined. Now it is time to link these entities in a relationship. In this 
example, we will link the entities with a one-to-many identifying relationship. 

Before actually drawing the relationship take a look at what the SA/SE’s help file has to say on the topic 
of “relation lines”. You can see this by opening the help file menu option Help -> contents tab -> Data 
modelling -> The entity relation model -> objects included in an ERD -> relation line -> introduction. The 
figure below shows this. 

 

 
Figure 18  Help about relation(ship) lines in ERDs 

Basically a identifying relationship is one where the child is dependent upon the parent entity. Do not 
worry at this stage if the find the variety of lines offered confusing. 

Now let’s draw the line! Return to the drawing toolbar and select the identifying relationship tool:  

Note that this is next to the selection tool button.  The mouse cursor will take on the shape of a pen with a 
jagged line next to it.  
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Place the cursor over the Travel Agent entity and click the left mouse button once. Then position the 
cursor over the Reservation entity and click the left mouse button again. It is not necessary to hold the 
mouse button down while moving to the second entity.  

A line representing the relationship will automatically be drawn between the two entities and a space will 
appear upon which the name of the relationship can be entered.  Type the word  makes  as the title of 
this relationship. We would like to imply that the travel agent “makes” the reservation (or in this case, 
many reservations). The relationship name can be changed or corrected by editing the relationship as 
described next.  

To edit the relationship, return to the tool bar and select the selection tool (the arrow). Right click on the 
relationship line and choose the Edit item from the pop-up menu. The Relationship dialog box will appear 
looking very similar to the one shown in Figure 19. Make any necessary changes to the names of the 
relationship and also add a relationship name for the reverse direction (called the Reverse Phrase).  

 

 

 
Figure 19  Relationship dialog box (SA/SE 2001 version) 

 

After defining an identifying relationship, the child entity (reservation) will be considered as a dependent 
of the parent entity (travel agent) and therefore will be presented by double border.  

If a relationship is specified incorrectly (for example if it is drawn in the wrong direction or between the 
wrong entities), it can be deleted by highlighting the relationship with the select tool and by then pressing 
the Del (Delete) key on the keyboard (or by pulling down the Edit menu and choosing the Delete menu 
item).  

Important: 

To save the work completed thus far, press CTRL + S or pull down the File menu and choose the 
Save Diagram menu item. Click “Yes” when asked to confirm.  
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3.4. Completing the diagram 
This is an exercise for you, an additional entity called Property will be created in the above diagram and 
then related to the existing Reservation entity. An outline of the steps follows:  

a) Use the Entity tool to add a new entity named “Hotel Room”. Place this below the Reservation entity.  

b) Add the following attributes to the Hotel Room entity:  

 

Name Primary Key (PK) Data Type Qualifier 

Property_code Yes character 10 

Unit_number Yes integer 10 

unit_type No character 10 

Owner_id No character 10 

 

c) Create an identifying relationship from Hotel Room to Reservation. Label this relationship “is reserved 
by” (reverse phrase is “a reservation for”)  

The final result should look like the figure below.  

 

Double border 
indicating that it is 

a dependent 
(child) entity 

Figure 20  Completed Entity Relationship modelling exercise 
 

You have now completed this tutorial, you can find additional exercises below along with tips and tricks in 
SA/SE. 

Important: 

To save the work completed thus far, press CTRL + S or pull down the File menu and choose the 
Save Diagram menu item. Click “Yes” when asked to confirm.  
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4. Exercises 
You are urged to practice developing ERDs in system architect to gain experience. Here are some 
suggestions: 

Convert the pen and paper exercises in the ERD tutorial at http://www.robinbt2.free-
online.co.uk/virtualclassroom/chap11/s9/erds_1.pdf  to SA/SE Erd’s. 

 
Work through the excellent data modelling tutorial in SA/SE. Besides the more up-to-date help file 
version, shown below, which has references to the student edition the PDF version can be used. I find 
this easier, printing it out and making notes on it while working at the computer, perhaps I’m just old 
fashioned! See figure 1 to see how to locate the pdf version, you should shart at chapter 14 logical data 
modelling page 187. 

 

 
Figure 28 System Architect online help and the Data Modelling tutorial 

 

5. Conclusions for this Tutorial  
In this tutorial, you learnt the basic steps for creating and manipulating ERD’s. The SA/SE product has an 
extensive number of additional model types as well as reporting tools. You should look at Popkin’s web 
site (see references section below) and also the excellent documentation and tutorials that are part of 
SA/SE to find out more.  

Most of this tutorial is the work of Dorothy Dologite and Richard Holowczak at the City University of New 
York you an see the original version at http://cisnet.baruch.cuny.edu/holowczak/classes/

 

The appendix contains useful tips for using SA/SE 

 

Robin Beaumont  03/01/2004 13:00 
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6. Tips and tricks 

6.1. Copying a diagram to a Word document 
To copy an ER Diagram, or any type for that matter! 

1. Open up the diagram 

2. Pull down the Edit menu and choose the Select All menu item. This will highlight all of the 
entities and relationships in the diagram.  

3. Pull down the Edit menu again and select the Copy menu item. This will place a copy of the 
diagram on the Windows clipboard in Enhanced Metafile format (this is usually the best format to 
use).  

4. Switch over to MS Word or other word processor, pull down the Edit menu and select the Paste 
menu item.  

If the picture is too large in your document, in SA/SE pull down the edit menu and select Clipboard 
format and select the required scale. Similary you can also change the format of the picture using this 
option. 

 

6.2. Changing the colours and fonts of diagrams  
It is possible to change the background color, line color and fonts (type style and size) for virtually any 
object in any of the diagrams SA/SE provides. One reason to change some of the colours is that they 
may not print clearly on black and white printers or may not photocopy well.  

To change the colours: 

1. Open up any diagram and select an object (e.g., an Entity or a Function).  

2. Pull down the Format menu, highlight the Symbol Style item  

3. Choose Colour from the fly-out menu. Choose the colours for the outline Pen, background Fill 
and font colours by clicking on the appropriate Colors button.  

4. Click the OK button when finished.  

In a similar fashion, the font can be changed by pulling down the Format menu, highlighting the Symbol 
Style item and then by choosing Font from the fly-out menu.  

To change the colours, fonts or other display attributes for a group of objects on a diagram, select 
multiple objects first (hold down the shift key while clicking on additional objects) and choose the 
appropriate menu item as described above.  

 

6.3. Linking Diagrams  
In the previous sections, we created and manipulated a single Entity 
Relationship diagram However, there are often relationships among 
different diagrams. For example, a single ER diagram may represent 
only a few of the entities being modelled and some of the entities on the 
diagram may have links with others on another diagram or even a 
different type of diagram. Similarly an entity in one ‘high level’ diagram 
may be exploded (‘nested’) in another one to show more detail. Linking 
diagrams enables system analysis and designers to quickly navigate 
between relevant portions of each of the different types of diagrams as 
well as make the connections between the models explicit. You can 
easy link diagrams by Right mouse clicking on the object you wish to 
create the link from and then selecting either child create or child 
attach. 

Figure 21 
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6.4. Project and Diagram Management  
The SA/SE provides only four encyclopedias named, tutorial, examples and Project1 to Project4. It is 
possible to “install” additional projects such as those passed along by a team member or provided from 
the class instructor. In the following exercise, assume a .ZIP file containing all of the encyclopedia files for 
a project have been made available to the student and have been downloaded to the local users hard 
disk.  

Make certain that SA/SE is not running  

Make a backup of existing projects by using the Windows Explorer to navigate to the C:\Program 
Files\Poplin Software\System Architect student version\ directory (this is the default directory used during 
the installation). Copy the Project1 and Project2 directories to another disk or another directory on the 
same hard disk for safekeeping.  

Use an unzip utility (such as WinZIP) to unzip the new project and its files. Again using Windows Explorer 
copy the set of files into the appropriate project directory such as C:\Program Files\Poplin 
Software\System student version\Project2  

The next time SA/SE runs, it will find these new project encyclopedia files in this directory and will 
automatically make use of them.  

6.5. Managing Diagrams within a Project  
While working on a project, it is often desirable to save several different version of the same diagram. For 
example, before embarking on a series of major changes to a diagram, one might wish to save off the 
current version for safekeeping or to reference as the subsequent changes are made. This can be 
accomplished by using the Save Diagram As menu item on the File menu.  

For example, suppose the designer wished to continue expanding the “Travel Agency 1” ER diagram 
created earlier in this tutorial while retaining the original. With this diagram open, pull down the File menu 
and choose the SaveDiagram As menu item. Provide a new name for this diagram (such as Travel 
Agency 2) and select the appropriate type of model as shown in the Figure below.  

 
Figure 22 

Once the name and type are chosen, click on the OK button. The Project Data Model dialog box may 
appear next. In this example, this new diagram will be saved in the same data model that was first 
created at the start of this tutorial (“Project Data Model 1”). This is shown in the Figure below. Click on the 
OK button and the newly named diagram will appear in the right hand window.  

 
Figure 23 
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6.6. Additional Features of SA/SE  
The SA/SE product has a vast number of features. In this section a collection of tips for using some of the 
more helpful features are briefly introduced.  

1.1.1. ER Model Display Mode Options  

In this tutorial an ER model was created that included the display of attributes with primary key 
descriptions. It is also possible to change how ER diagrams are displayed. Try the following exercise. 

Open up the ER Diagram (Go to the All Methods tab, Diagrams, Entity Relation and then double click on 
the “Travel Agency 1” diagram).  

Highlight/select one of the entities on the diagram, pull down the View menu and choose the Display 
Options menu item. The resulting dialog box is shown below. The display mode choices are as follows:  

Entity Relation – Only entities with titles and relationships are shown  

Key Based – Entities with titles and their identifiers (keys) with relationships are shown  

Fully Attributed – Entitles with all attributes including keys and relationships are shown  

Physical – Same as Fully Attributes with the addition that data types for each attribute are shown  

 
Figure 24 

 

1.1.2. Including Foreign Keys in ER Diagrams  

Foreign keys are general not shown in traditional ER modeling. However, prior to creating a physical data 
model based upon the conceptual ER model, the designer may wish to view how foreign keys will be 
propagated through the model. To perform this change in SA/SE: 

1. Open up an ER Diagram and make certain the Fully Attributed display mode is set.  

2. Pull down the Dictionary menu and select the Update FKs menu item.  

3. A dialog box will appear showing a log of the changes made to the diagram. Upon dismissing this 
dialog box, the ER Diagram will redraw with the foreign keys in place.  

To remove the foreign keys, pull down the Dictionary menu and select the Remove FKs menu item.  

Robin@organplayers.co.uk                            C:\edinburgh\msc unit 6\ss_tut_1_erd\sa_erd1.doc                                Page 18 of 22 



System Architect version 8.8.16 Student Edition Tutorial 1 ERDs 

1.1.3. Changing the Symbol Style for ER Diagrams  

The default symbol style for the ER diagrams is called the “Crow’s feet” notation. In this notation a single 
relationship line indicates a maximum relationship cardinality of “1” while the crows foot (three small lines 
at the end of the relationship line) indicates a maximum relationship cardinality of “Many”. There are other 
notations that explicitly give the minimal and maximal cardinalities in terms of number and in terms of 
other types of symbols. To change the notation used for the ER Diagram: 

1. Open up the diagram 

2. Pull down the Format menu, choose Diagram style and finally Notation from the flyout menu.  

3. The Notation options dialog box is shown below.  To see the differences in notation, try selecting 
C-Y (short for Coad-Yourdon) or Unified for example.  

 

 
Figure 25 
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1.1.4. Adding Documentation to a Diagram  

It is important to include documentation on each diagram so that they can be easily identified. 
Documentation can be easily and automatically added to any diagram using the “Doc Block” drawing tool 
(shown below). Open up any diagram and select the Doc Block icon or, pull down the Drawing menu and 
choose the Doc Block menu item. The cursor should change to a pen.  

 
Figure 26 

 

Find some open space on the diagram and click once. The documentation block is automatically added. 
Once created, the documentation block can be re-sized and re-positioned using the selection tool. 
Additional comments can be added by right-clicking on the block and choosing the Edit menu item from 
the pop-up menu as shown below.  

Figure 27 
 

Robin@organplayers.co.uk                            C:\edinburgh\msc unit 6\ss_tut_1_erd\sa_erd1.doc                                Page 20 of 22 



System Architect version 8.8.16 Student Edition Tutorial 1 ERDs 

 

Robin Beaumont  24/12/2003 16:09 

Robin@organplayers.co.uk                            C:\edinburgh\msc unit 6\ss_tut_1_erd\sa_erd1.doc                                Page 21 of 22 



System Architect version 8.8.16 Student Edition Tutorial 1 ERDs 

7. References  
Kendall and Kendall. 1999 Systems Analysis and Design. Fourth Edition. Prentice Hall.. Web site: 
http://www.prenhall.com/kendall//  

Shelly, Cashman and Rosenblatt. 1998 3rd ed Systems Analysis and Design.. International Thomson 
Publishing January  ISBN: 0789542668  

Jeffrey Hoffer, Joey George and Joseph Valacich. 1999 2nd ed Modern Systems Analysis... ISBN: 0-201-
33841-6 Web site: http://www.prenhall.com/hoffer/  

Popkin System Architect Product   Web Site: http://www.popkin.com/  

Popkin System Student Edition – additional Help Files and Tutorials   Web site: 
http://www.popkin.com/products/sa_student_edition/sa_student_edition.htm  

 

Robin@organplayers.co.uk                            C:\edinburgh\msc unit 6\ss_tut_1_erd\sa_erd1.doc                                Page 22 of 22 

http://www.prenhall.com/kendall/
http://www.prenhall.com/hoffer/
http://www.popkin.com/
http://www.popkin.com/products/sa_student_edition/sa_student_edition.htm

	Introduction
	Where to obtain the software
	Before you begin this tutorial?
	What are the aims of this tutorial?

	Starting Up SA/SE
	Data Modeling using Entity Relationship Diagrams
	Creating a new diagram
	Editing Names and Attributes for the Entities
	Defining a Relationship among the Entities
	Completing the diagram

	Exercises
	Conclusions for this Tutorial
	Tips and tricks
	Copying a diagram to a Word document
	Changing the colours and fonts of diagrams
	Linking Diagrams
	Project and Diagram Management
	Managing Diagrams within a Project
	Additional Features of SA/SE
	ER Model Display Mode Options
	Including Foreign Keys in ER Diagrams
	Changing the Symbol Style for ER Diagrams
	Adding Documentation to a Diagram


	References

